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Introductie

Xrit2pic is een programma dat HRIT/LRIT/AVHRR gegevens behandelt, die zijn verzonden door Eumetsat via 
satelliet en internet. Ondersteunde gegevensformaten omvatten:

-  HRIT en LRIT, gebruikt door de nieuwew Meteosat Second Generation (MSG, zoals Meteosat 8 enz).
-  Gegevens van oudere satellieten, zoals Meteosat 7 en daarvoor, GOES en MTSATR, 

geformateerd als LRIT.
-  LRIT van Amerikaanse geostationaire satellieten.
-  AVHRR van polaire satellieten:
         - NOAA (geformateerd als bzipped HRPT)
         - METOP (geformateerd als EPS)
-  DWDSAT: beperkte ondersteuning
  
Afbeelding gegevens kunnen direct worden bekeken, of omgezet naar standaard beeldformaten. Xrit2pic kan 
enige eenvoudige gegevens bewerkingen doen, zoals pseudo kleurenbeelden kunnen worden gegenereerd door 
het in kaart brengen van meerdere kanalen naar verschillende kleuren. Sommige speciale kaarten, zoals mist en 
stof/zand  detectie, zijn ingebouwd. Xrit2pic kan ook anaglyphen (3D afbeeldingen) genereren; de helderheid 
wordt omgezet in hoogte. 
Bovendien kunnen films worden gemaakt en is ook mogelijk in combinatie met alle vermelde features. Voor 
polaire satellieten kunnen de banen worden uitgezet op een wereldkaart; keuze van een deel van de baan of 
exporteren, wordt ondersteund. Alle gegevens verwerking wordt gedaan door het direct gebruik van de ruwe 
(raw) bestanden, zonder genereren van tussenbestanden.

Hieronder een schets van de plaats van xrit2pic in een MSG ontvangst omgeving.

     
 - De Skystar2 tuner is een standaard TV satelliet tuner (een PCI uitbreidingskaart of een externe tuner  
   verbonden via USB)
- De Tellique sofware haalt de gegevens uit de tuner en zet ze op een harde schijf. Dat programma is    

   beschikbaar van Eumetsat. Om alle gegevens te ontvangen is een speciale USB code nodig, zonder die code
   is  alleen een zeer beperkte hoeveelheid gegevens beschikbaar. Voor meer informatie zie:

                 http://www.eumetsat.de/
- Mencoder is een externe film generator. Het is een optie; xrit2pic kan nu direct films maken (in avi formaat).

  Notitie: Dit is alleen een voorbeeld, gegevens van de Eumetsat ftp service, op een CDROM enz. zijn ook 



  geschikt om door xrit2pic te worden behandeld.

xrit2pic  is beschikbaar voor Linux en Windows. Het is ook te compileren voor andere systemen
 (Sun/Solaris MAC enz.); de bron code is beschikbaar. Eumetsat ondersteunt alleen de Linux en Windows 
  systemen (zover bekend), voor de Tellique software.

Normaal heeft xrit2pic niet veel PC geheugen nodig:

   - Wanneer de GUI loopt: 12M
   - Bekijken van een venster met een HRIT afbeelding: 40M
   - Bekijken van een venster met een samengestelde afbeelding van 3 kanalen: 90M

Wanneer HRV kanalen worden gebruikt is meer geheugen nodig:

   - Bekijken van een venster van een HRV kanaal: 105M
   - Tonen van een samengesteld hoge resolutie afbeelding met gebruik van 4 kanalen: 210M
   - Idem, maar houdt het samengestelde beeld in het geheugen voor snel zoomen: 722M

In het laatste geval is tenminste 512M RAM geheugen nodig.

  Voor METOP kunnen meer PC hulpbronnen nodig zijn. Gegevens van die polaire satelliet kunnen practisch 
  eindeloos  zijn ; een set gegevens van een overkomst kan meerdere banen inhouden. Om een complete 
  overkomst te laten zien is  nog mogelijk met 512 M geheugen, als geen andere grote programmas actief zijn.

Ik gebruik een compleet MSG ontvangststation met gebruik van Linux op een 2.4 GHz PC met 12M geheugen.
Dat is genoeg om afbeeldingen te ontvangen, de ontvangen beelden automatisch te tonen en opzoeken en tonen 
van eerder opgenomen afbeeldingen, alles tegelijkertijd, zonder verlies van de binnenkomende gegevens.
(Dat is, zonder METOP gegevens te bekijken!)
Het laten lopen van meerdere xrit2pic's parallel, is geen probleem. Xrit2pic kan echter bestanden verwijderen of  
verplaatsen (op verzoek natuurlijk); als een tweede xrit2pic dezelfde gegevens gebruikt kan dit verwarrend zijn.

Ondersteunde formaten

De volgende input formaten worden ondersteund:

     -  HRIT
     -  LRIT
     -  10 bits per pixel gewoon formaat
     -  8 bits per pixel gewoon formaat 
     -  HRPT formaat van NOAA
     -  EPS formaat van METOP
     -  Administratie berichten (tekst)  
     -  JPEG bestanden van David's MSG Data Manager
     -  DWDSAT formaten: 
                 - momenteel alleen bestandsmanagement
                 - bekijken door het starten van een externe viewer.
                 - exporteren door de gegevens naar een bestemmings bestand te copieren

 

Instellingen



 Xrit2pic heeft voorinstellingen voor praktisch alles. Zij kunnen worden gewijzigd in het Preferences onderdeel.
 Gebruikers instellingen worden opgeslagen onder xrit2pic.ini in de map waar het programma wordt gestart.

Daarnaast kunnen de gui status van het hoofdscherm en enkele pop-ups worden opgeslagen; bij het opstarten 
wordt de toestand van alle toetsen en keuzen in die vensters hersteld. De gui status is opgeslagen in xrit2pic.gini.

Er zijn 3 plaatsen waar xrit2pic.ini en xrit2pic.gini worden gezocht na het starten van xrit2pic.:

     - Map waar xrit2pic wordt gestart.
     - in $HOME map (Windows: C:\)
     - Op dezelfde lokatie waar het programma is geinstalleerd.

Het eerste xrit2pic.ini/xrit2pic.gini bestand dat wordt gevonden wordt gebruikt.

De 2 meest belangrijke instellingen zijn:

     -  Bron lokatie: Waar Tellique de bestanden neerzet; als voorinstelling:
              o Linux:: from_msg/received
              o Windows: c:\Program Files\T-Systems\Business TV-IP\received\
     -  Bestemmings lokatie: De plaats waar de omgezette beelden worden neergezet; als voorinstelling:
              o Linux: de lokatie waar het programma is gestart.
              o Windows: C:\

Beide bestanden zijn in ASCII, dus zij kunnen met een teksteditor worden gewijzigd, indien gewenst.
Voor meer informatie betreffende de instellingen, zie hoofdstuk Inrichten van Mappen en Voorkeuren.

Xrit2pic en MSG Gegevens manager

Xrit2pic gebruiken in combinatie met David Taylor's Data Manager, kan problemen geven
Beide programmas verplaatsen en/of verwijderen ontvangen gegevens, waardoor "interferentie" ontstaat.
 
  o xrit2pic verplaatst ontvangen gegevens naar received/done, in de record mode.
  o MDM verwijdert onbewerkte gegevens (raw data) na vertaling, of verplaatst raw data naar een bepaalde 
     directory.

Het resultaat is dat beide programmas verloren segmenten kunnen hebben.
Er zijn een paar methodes om beide programmas te gebruiken, maar het belanrijkste is:

  o Gebruik xrit2pic en MDM niet samen met dezelfde "received" map.

Er is een uitzondering: U kunt tesamen MDM voor MSG gebruiken en xrit2pic voor AVHRR, als
U David's AVHRR Manager niet heeft. Xrit2pic heeft een speciale AVHRR mode, die het "blind"
maakt voor MSG gegevens. MDM is toch al "blind" voor AVHRR. Dus zal MDM geen AVHRR bestanden
gebruiken en xrit2pic zal geen andere dan AVHRR bestanden gebruiken. Dat voorkomt conflicten tussen 
de 2 programmas.
Als xrit2pic in de continu update mode is (zie opslaan) en in de AVHRR mode, dan zou MDM  geactiveerd 
moeten zijn. Anders zal de 'received' map een hoop bestanden krijgen, en zal xrit2pic meer en meer tijd nodig 
hebben om die map te analyseren, om te zien of nieuwe bestanden zijn toegevoegd. (Dat is de reden waarom 



beide programmas proberen de  received map leeg te houden!)

Hoofdvenster

Onderstaande figuur geeft een indruk van het programma:

     
        De blauwe regels geven de beschikbare "sessies". d.w.z. ontvangen beelden op een bepaalde tijd en type   
        (LRIT of HRIT)
              o De code in de kolom 'Format' laat afgekort de beschikbare kanalen zien; V= zichtbare spectrum,
                 I=Infrarood, W=waterdamp.
     - Dubbel klikken op een blauwe regel zal alle ontvangen kanalen van die sessie laten zien.
        Een kanaal is kompleet, d.w.z. alle segmenten zijn beschikbaar, als het groen gekleurd is.
        Een kanaal waarvan een of meerdere segmenten ontbreken, is rood gekleurd.
              o De kolom 'Format' laat de compressie methode zien, gebruikt voor het ontvangen beeld. 
                (Wavelet,  JPEG).



              o De kolom 'Segments' toont het aantal onderdelen (bestanden)  voor ieder kanaal: huidig aantal         
                 en verwacht. Normaal zijn die twee getallen gelijk.

        Voor een correct weergeven van  HRV kanaal is het proloog bestand nodig. Wanneer dat bestand 
        ontbreekt  is de HRV regel geel gekleurd.

     - Wanneer een gewenst kanaal wordt geopend, zal dit alle segmenten van dat kanaal laten zien.
              o De kolom 'Format' toont nu de grootte van ieder segment.
              o De kolom 'Segments' laat het segment getal zien.
              o De kolom 'Channel' geeft een ruwe schatting van het breedtegraadbereik van ieder segment.

Een keuze kan op verschillende manieren worden gedaan:

      - Kies een groep kanalen door op een blauwe regel te klikken.
      - Kies een kanaal door op een groene (of rode) regel te klikken.
      - Kies een segment door op een zwarte regel te klikken. 

Meerdere keuzen zijn mogelijk, voor groepen, kanalen, segmenten:

      - Klik op het eerste te kiezen item, houd de muistoets ingedrukt en beweeg de muis naar het laatste item,
         laat dan de muistoets los.
      - Of: Klik op het eerste te kiezen item, scrol naar het laatste item, druk dan op de shift toets en klik op het
         laatste item. Alle items ertussen worden gekozen.
      - Om enkele items aan een keuze toe te voegen: Druk op de control-toets en klik op het toe te voegen item.

Toetsen in het hoofdvenster

Om een keuze gemakkelijker te maken, kunnen sommige items in de lijst worden verborgen, door de tweede
toets onder 'List ' (nu 'All '); bijv. alleen HRIT afbeeldingen kunnen zichtbaar gemaakt worden, of alleen LRIT,
MET7 items,enz.

Expand: Uitbreiding met een niveau, zodat alle kanalen zichtbaar worden. Nogmaals klikken  zal de lijst
sluiten.

Menu items

     -  File -> Reload: Verwijder de lijst en lees de bronmap inhoud opnieuw. (Zie ook 'Update 1x' onder de
         Recording alinea)
     -  File -> Raw data: Maakt een tekst bestand dat gekozen items bevat. Het laten lopen van dit bestand zal
         een 'ls'('dir') doen voor alle items. Door de ls (dir) opdracht te vervangen kan 'alles' met de gekozen items



         worden gedaan (bijv. verplaats ze naar een andere map).
     -  File -> Filenames selected: Laat de bestandsnamen zien, verbonden met de gekozen item(s). 
     -  File -> Fileinfo selected: Laat gedetailleerde info zien (hoofd inhoud) of gekozen item(s)
     -  File -> Archive selected: Gekozen archief items (pop-up om archief plaatsing te kiezen)
     -  File -> Delete Old: Verwijderen van oude items (zie Voorkeuren)
     -  File -> Delete Selected: Verwijder de gekozen item(s) in de lijst. Notitie: Verwijderen van AVHRR be-
         standen kan alleen na kiezen van een blauwe regel. Aparte kanalen kunnen niet worden verwijderd, want
         alle kanalen zitten in een bestand.
     -  File -> Delete temp.movie files: Dit is speciaal nodig als film bestanden automatisch zijn gemaakt met
         recent ontvangen gegevens. Films worden gegenereerd van aparte jpeg bestanden, die in een speciaal be-
         stand worden gezet. Om geheel opnieuw te beginnen, moet dit bestand worden leeggemakt. Zie ook
         (Generation of movie)
     -  File ->  Show Overlay files: Laat alle overlay bestanden zien (zie ook Bedekken met landsgrenzen).

     -  Edit -> Preferences: Zie Voorkeuren
     -  Edit -> Save gui state: Sla de instelling van de toetsen op; die instellingen zullen worden ingesteld na een
        herstart.

     -  Projections -> AVHRR lin:  Lineariseer AVHRR afbeeldingen
     -  Projections -> Proj ->: Gebruik speciale kaartsystemen
                       o Plate Carree
                       o Mercator
                       o Polar North
                       o Polar South
 
     -  View -> lon_lat: Voeg lengte en breedte lijnen toe aan de beelden.  
     -  View -> Exported: Na drukken op Export en het genereren van het bestand, wordt een kijkbestand ge-
         start die het gexporteerde beeld laat zien. (Zie Voorkeuren)
     -  View -> Anaglyph: Dit voor het bekijken/exporteren van afbeeldingen in 3D. Om 3D beelden te kunnen 
         bekijken is een bril met  rood/cyaan glazen nodig.
     -  View -> IR=Temp: Zet de kaart van IR afbeeldingen op een kaart van een gekleurde temperatuur kaart.
         (rood= heet, blauw=koud)
     -  View -> Fires: Detectie van branden

     -  Gebied: Kies gebied voor geostationnaire satellieten. De keuzen (namen en gebieden) hangen af van wat is 
         gedefinieerd in Preferences (Algemene deel).  Voorinstelling:
                 o  Europe: Alleen het Europa deel van de beelden zal worden getoond/geexporteerd
                     (afmeting = 1/4 x 1/4 van het origineel)

 Na keuze van een of meer items, kan een voorvertoning (Preview) of bestand generatie worden uitgevoerd.

Basis bewerkingen

Voorvertoning (Preview)

    -  Kies de afbeelding die moet worden getoond.
     -   Klik op 'Preview'. De gekozen afbeelding (of bericht) is nu zichtbaar.
            o  Om in te zoomen, druk op 'i'
            o  Om op een bepaald deel in te zoomen, plaats de cursor daar en druk op 'I'



            o  Om uit te zoomen, druk op 'o'   
            o  Maximum zoom, druk op 'f' of  'F'
            o  Door een afbeelding scrollen met de pijltoetsen of de scroll balken.
Notitie: In de bovenste balk van het venster zijn de volgende gegevens te zien:
            o  Z=[x,y] : zoom factors
            o  N=[x,y]: zichtbare pixel bereik
            o  D=[x,y]: afbeelding pixels per scherm pixel. Een waarde van 1 betekent: een beeld pixel ligt precies
                op een scherm pixel.
    -   Menu items:
           o  View -> Lumgraph: Pop-up met grafieken voor RGB en helderheid.
           o  View -> Zoom:
                    * Values: Toetsen toevoegen voor fijnafstemmen van de zoom.
                    * Full: Volledig ingezoomed (toets: 'f')
                    * Full: Inzoomen (toets: 'i')
                    * Full: Uitzoomen (toets 'o')
           o  View -> Redraw: Beeld opnieuw schrijven
           o  View -> Flip: Voor het geval dat de afbeelding ondersteboven staat; is normaal niet nodig.
           o  View -> Invert: Om de helderheid om te keren, bijv. voor IR afbeeldingen
           o  View -> Projection: Verander de projectie in:
                     * Plate Carree, Mercator, Polar North, Polar South.
           o  View -> Overlay: Schakel overlay (bedekken) in.
           o  View -> Lon-lat: Voeg lengte/breedte lijne toe.          
           o  View -> Temperature: Schakel de temperatuurkaart in voor IR Afbeeldingen
           o  View -> Scatterometer: Pop-up voor toevoegen van scatterometer resultaten aan de afbeelding.
           o  View -> Square pixels: x/y evenredig, d.w.z. de aarde wordt als een cirkel getoond, onafhankelijk
                van de afmetingen van het venster.
           o  View -> Fast: De behandelde afbeelding wordt in het geheugen gehouden. Daardoor is zooming/
                panning veel sneller, maar wordt meer geheugen gebruikt.

           o   File  -> Save jpeg: Sla het (zoomed) beeld op in jpeg formaat.
           o   File  -> Save pgm: Sla het (zoomed) beeld op in pgm formaat.
           o   File -> Save pgm8: Sla het (zoomed) beeld op in 8 bbpp pgm formaat, ook als de bron 10 bpp is.
           o   File -> Screendump: Sla het complete beeldscherm op in 8bbpp pgm formaat.

           o   Lum: Bereken het in kaart brengen van optimale helderheid.
           o   Hue: Zet RGB op dezelfde bijdrage.
           o   Lmin, Lmax: Stel handmatig de helderheidsgrenzen in. Ook veranderd door Autolum.
           o   Frz clr: Voor samengestelde beelden, stel de kleurkaart vast in.
           o   More: Opent meer instellingen enz.:
                      -  Ovl_dim: verlaag de helderheid van de overlay lijnen.
                      -  Pos: Dat veld laat de positie van de cursor zien (AVHRR, als een Keplerbestand beschikbaar
                          is: laat lengte/breedte zien.
                       - Val: Waarde van de pixel (wanneer in de temperatuur kaart, voor IR kanalen: laat de tem-
                          peratuur zien bij de cursor in graden Celsius.
                       -  Gamma: Stel de gamma correctie in.                              
    -  Extra zichtbare toetsen wanneer Anaglyph wordt gekozen: (zie Anaglyph voor meer details).
           o   Shift: De maximum hoeveelheid verschuiving (in pixels) tussen rood (links) en cyaan (rechts).
           o   Lbnd, Hbnd: laagste en hoogste grens; verschillen in diepte worden getoond tussen deze twee
                niveaux.
           o   Init: Klik dit aan om de Lbnd en Hbnd niveaux op een eenvoudige manier in te stellen.
           o   Bpthchan: Kanaal gebruikt voor diepte informatie. Wanneer niet gekozen wordt de helderheid van
                de afbeelding zelf gebruikt. Wanneer gekozen wordt een toegewezen kanaal gebruikt.



                (zie Voorkeuren). Vooringesteld is dit kanaal 9 (IR_108)
           o   OL_3D: Wanneer 'overlay' is gekozen (zie hoofdvenster) dat wordt de dekking getoond op het 
                "diepste" niveau. Wanneer niet wordt gekozen wordt de dekking getoond als een getrokken witte 
                lijn, als in non-anaglyph mode.
           o   OL_lum: Helderheid van 3D dekking.

Notitie:     
    -  De voorvertoning (Preview) instellingen (zooming, inverting, flipping, helderheid instellingen, enz.) worden 
        meegenomen, als de afbeelding wordt opgeslagen met het 'File -> Save' menu item van het voorvertoon 
        venster.
    -  'Save pgm': Exakte formaat hangt af van de afbeelding die wordt opgeslagen:
           o   kleur geeft PPM formaat.                   
           o   van HRIT geeft PGM 16 bits per pixel.
           o   van LRIT geeft PGM 8 bits per pixel.

Notitie: 
Maken van een afbeelding voor de eerste keer zal wat tijd nemen, omdat de gegevens moeten worden gede-
comprimeerd. (Voor een hoge resolutie kleuren afbeelding moeten 4 afbeeldingen worden gedecomprimeerd).
Om het opnieuw schrijven te versnellen:

           o   Zorg ervoor dat 'Memory usage: Minimize ' is Off!. (Zie Voorkeuren). De gegevens zullen in geheugen
                worden gehouden zo lang het voorvertoon venster open is.
           o   Als U genoeg geheugen hebt (tenminste 512 MB): Kies 'View -> Fast'. Dat zal speciaal samengestelde
                afbeeldingen (kleur, hoge resolutie kleur) versnellen.
                (Gegevens worden na samenstelling in geheugen gehouden).
           o   Geinteresseerd in alleen Europa: Kies 'Europa' in de hoofdvenster menu balk.
           o   Als U wilt inzoomen tijdens omzetten en schrijven: Doe dit nadat de afbeelding is getekend. Alleen 
                zichtbare segmenten worden omgezet; het is niet nodig om op de complete afbeelding te wachten, 
                alvorens op een bepaald deel in te zoomen. (Zoomen heeft geen onmiddellijk effect; eerst moet de
                vertaling van een segment gereed zijn).

Export

    -  Kies de afbeelding (of bericht) dat geexporteerd moet worden (bijv. maak een bestand).
    -  Kies 'Compose' om een kleuren afbeelding te genereren (hiervoor moet een groep, d.w.z. blauwe regel,
       gekozen worden.
    -  Kies 'Europe' en/of  'Anaglyph' , indien gewenst.
    -  Klik op 'Export'.

Het vooringestelde formaat van de geexporteerde afbeelding hangt af van het formaat waarin het werd ontvangen:
 
    -  PGM16 voor afbeeldingen verzonden in Wavelet 10 formaat (d.w.z. HRIT)
    -  PGM8 voor afbeeldingen verzonden in Wavelet 8 formaat  (d.w.z. foreign LRIT)
    -  PPM voor kleurenafbeeldingen verzonden in Wavelet  8 formaat (d.w.z. foreign LRIT).
    -  JPEG voor afbeeldingen verzonden in JPEG formaat (LRIT MSG)
    -  Voor AVHRR: 
           o  RAH als een groep (blauwe regel) is gekozen en geen 'colour map' venster is open.(Alleen NOAA!)
           o  PPM als een groep (blauwe regel) is gekozen en 'colour mapping' is open.
           o  PGM16 als een kanaal (groene regel) is gekozen.

Notitie: RAH is hrpt 10 bits per pixel formaat. Dat kan gelezen worden door:



           o  wsat zie voor formaat "10Bformat".
           o  HRPTReader (van David Taylor)
Zie "Andere kenmerken" voor wijzigen van het formaat.

Als de afbeelding moet worden geexporteerd met speciale opties, bijv. gezoomd, speciale helderheid instellingen,
enz., gebruik het File->Save menu in het voorvertoon venster

Gegevens behandelen

Inhoud: 
          
           o  Bedekken (Overlay)
           o  Samenstellen (kleuren afbeeldingen)
           o  Speciale kaartsystemen
           o  Hoge resolutie afbeeldingen
           o  Wanneer zal wat worden gegenereerd
           o  Anaglyphen

Bedekken (Overlay) voor MSG: Landsgrenzen etc.

Download eerst de overlay bestanden:  http:/oiswww.eumetsat.org/WEBOPS/coastlines.
Download de gif bestanden die U wilt of download 'coastlines.zip' en unzip. 
Verander de namen van de bestanden niet. Zet ze op de volgende lokaties:

           o  Op dezelfde lokatie als waar het programma is geinstalleerd.
           o  Map waarin xrit2pic wordt gestart (aanbevolen)
           o  in $HOME map (Windows : C:\)

xrit2pic gebruikt dezelfde algoritme als voor het xrit2pic.ini bestand.
Kies 'Overlay' en selecteer de soort overlay die U wilt (voorinstelling: landsgrenzen).
Notitie: xrit2pic bepaalt welke overlay te gebruiken met de volgende informatie:

           o  Satelliet: MSG (meteosat 8), of meteosat 7/6/5.

         o  Getoonde kanaal
           o  Gekozen overlay

           o  Een ingebouwde tabel die het type afbeelding verbindt met een bestand waarin de overlay zich bevindt.
               (daarom moet U de bestandsnamen niet veranderen).

Bedekken (Overlay) voor AVHRR: lengte/breedte lijnen

Download eerst het Kepler bestand voor NOAA's van: http://www.celestrak.com/NORAD/elements/noaa.txt.
Dat bestand wordt 'noaa.txt' genoemd en bevat de Kepler gegevens voor alle NOAA's en METOP. Opm: De 
bestanden moeten niet te oud zijn, voor maximum nauwkeurigheid. Dus moet dat bestand van tijd tot 

tijd worden
vernieuwd. De lat/lon lijnen zijn berekend en toegevoegd als 'overlay' is gekozen. De naam van het 

noaa bestand
(voorinstelling 'noaa.txt') mag worden veranderd in de preferences.



Kleuren afbeeldingen

Wanneer een blauwe regel is gekozen, zal een kleurenafbeelding kunnen worden gegenereerd; klik op 'Enable'
in de 'Colours' box. Vooringesteld wordt het volgende ontwerp gebruikt:
  

red green blue 

HRIT IR016 VIS008 VIS006 
LRIT IR016 -- VIS006 
AVHRR Ch1 Ch2 Ch4 

                              
Deze voorinstellingen worden overschreven met de -r, -g, -b, -ro, -bo opdracht opties. Zie Non-gui mode.

Met de toets 'Mapping' komt een venster te voorschijn waarin U het ontwerp kunt wijzigen.

Bijdrage van ieder kanaal aan iedere kleur kan worden gewijzigd met de "up/down" toetsen onderaan het ven-
ster, tussen +100 en -100%. Voor iedere kleur kan een verplaatsing (offset) worden gedefinieerd. 
Berekening van de bijdrage van ieder kanaal hangt af van de 'Mirror neg. values' toets.



    -  Wanneer aangeklikt:
            o  waarde=ABS(val_chan1*fact1 + val_chan2*fact2 + ...)
    -  Wanneer niet aangeklikt:
           o  waarde=offset  +  val_chan1*fact1 = val_chan2*fact2 + ... 
               Een negatieve waarde zal in 0 worden veranderd.

Met een offset, ongelijk aan 0, is het mogelijk de bijdrage van een kanaal om te keren: zet offset op +100 en bij-
drage op -100.
(In principe is het niet nodig om de offsets voor ieder kanaal apart te definieren; offsets voor alle kanalen worden
eenvoudig opgeteld.

Enige vooringestelde kleurontwerpen zijn ingebouwd:

o  Normale kleur
o  Mist nacht detectie
o  Mist dag detectie
o  Stof detectie
o  Luchtmassa
o  Verschillende microphysic kleurontwerpen 

Die kunnen worden gekozen met de toets rechts onder, aangegeven met "ngrb' (normaal RGB, dat is voorin-
gesteld).

Speciale Kaarten venster

De speciaal vermelde kaarten, zoals luchtmassa, mist, enz. gebruiken een kanaal of het verschil van twee kanalen
voor iedere kleur. Xrit2pic heeft een speciaal kaarten venster om die soorten kaarten op te geven. Temperatuur-
grenzen kunnen direct worden opgegeven. Wanneer een speciaal soort kaart is gekozen dan zullen de waarden
zichtbaar zijn in dat venster en zij kunnen eenvoudig worden aangepast, indien gewenst. Zie de afbeelding hier-
onder: iedere kleur kan maximaal 2 toegevoegde kanalen hebben. De rechtse (in kolom "Chan N") zal worden
afgetrokken van de linker ("Chan P").
De volgende 2 kolommen (Temp H, Temp L), geven de temperatuur grenzen aan waartussen de kanaalcombinatie
op kaart is gezet. Bijv.: In de afbeelding hieronder, is kanaal IR_108 afgetrokken van IR_120. Een verschil van
-4 Kelvin en lager, zal als "Zwart"worden weergegeven, een verschil van +2 Kelvin en hoger, maximaal Rood.
Tussen -4 K en +2 K, hangt de kaartweergave af  van de gammacorrectie, gamma 1 geeft een lineaire weergave.

Na wijziging van een instelling , klik op "Set", om het effectief te maken.
Wanneer een kanaal niet beschikbaar is, zal de toets rood gekleurd zijn. 



Hoge resolutie kleurenafbeeldingen

Hoge resolutie kleurenafbeeldingen zijn mogelijk door het HRV kanaal voor helderheid en andere 
kanalen voor

de kleur te gebruiken.
Schakel 'Colour' en 'Hires' in. Zie hierboven voor het kiezen van andere dan de vooringestelde kanalen voor de
kleuren ontwerp. Gebruik niet HRV voor een van de kleuren.
Notitie: Voor een perfect ontwerp van HRV naar andere kanalen is het nodig dat het proloog bestand aanwezig
is. (ie PRO_EPI in de sessielijst). In dat bestand zijn de exacte posities van het onderste en bovenste deel ge-
definieerd. Wanneer dat bestand niet aanwezig is, worden vooringestelde waarden voor de verschuiving van het 
bovenste deel gebruikt. ( Die waarden wijzigen voor bijna iedere afbeelding, dus is het belangrijk het proloog
bestand beschikbaar te hebben).

Wanneer zal wat worden gegenereerd.

Wanneer een groep (blauwe regel) is gekozen, zijn er verschillende mogelijkheden wat zal gebeuren na op Preview
of Export te klikken:
     o  Colour  en Hires zijn niet gekozen
          Een groep kiezen betekent: alle kanalen kiezen, als aparte grootheden. Klikken op Preview of Export geeft 
          een pop-up venster waarin U kunt kiezen welke kanalen moeten worden bewerkt. Resultaat: een 

afbeelding 
 voor ieder kanaal.

 o   Colour is  gekozen, Hires niet.
      Alleen een beeld zal worden gegenereerd, met gebruik van de kanalen van de groep en een 
mapping die 
      aangeeft welke kanalen in kaart moeten worden gebracht op welke kleuren. Diverse mappings 
zijn inge-
      bouwd, te kiezen met de keuze toets voor nrgb, fog, dust, en airmass. Zij kunnen worden 
gewijzigd door
      openen van het 'colour map' venster.
      Opm. Het HRV kanaal kan ook worden gebruikt.
 o   Colour en Hires zijn gekozen.
      Hetzelfde geldt, maar nu worden de lage oplossing kanalen gebruikt om de kleur te definieren; 
de helderheid
      is weggefilterd. In plaats wordt nu het HRV kanaal gebruikt voor definieren van de helderheid.
      Het HRV kanaal dekt niet de gehele aarde af, dekt feitelijk een L-vorm af.  Xrit2pic maakt het 



beeld zodanig
      rechthoekig  dat alle HRV onderdelen aanwezig zijn. Op plaatsen waar geen HRV is, zullen de 
lage oplossing 
      kanalen worden gebruikt op de normale manier, alsof Hires niet was gekozen.

Wanneer meerdere groepen zijn uitgekozen, en kleur is ingeschakeld, zal het pop-up venster 
tevoorschijn komen.
 Dat is speciaal nuttig bij exporteren; in het pop-up venster kunt U definieren hoe een film te 
genereren. Ook laat
 het pop-up venster de voorgang zien van het proces.

Anaglyph 

Zie Details betreffende het genereren van anaglyphs.  

Geografische kaartsystemen

Momenteel is een speciaal kaartsysteem geimplementeerd, Plane Carree (of zoiets).
Opm: Dit kaartsysteem is niet precies gelijk aan Plane Carree: kijk naar de lengte/breedte lijnen met overlay inge-
schakeld!

Vertalen van meerdere afbeeldingen

Genereren van meerdere afbeeldingen

Wanneer meerdere afbeeldingen worden gekozen, dan zal, na klikken op 'Preview' of ' Export' een venster
openen met alle gekozen afbeeldingen.
(Notitie: Wanneer een blauwe regel is gekozen, maar kleur niet ingeschakeld, dan worden alle kanalen onder 
die regel gekozen als aparte afbeeldingen. Dus zal het vermelde venster openen)

    -  Kies welke kanalen moet worden omgezet. Bijv. als 10 HRT-sets zijn gekozen, dan is het mogelijk om
        afbeeldingen te genereren voor alleen VIS006 en VIS008. Dat zou 20 afbeeldingen opleveren.
    -  Kies het output formaat (pgm, jpeg, voorinstelling)
    -  Wanneer gezoomde afbeeldingen moeten worden gegenereerd:
          o  Klik op 'Preview' in het geopende  venster (NIET in het hoofdvenster). Een speciaal voorvertoon 
              venster met de eerste gekozen afbeelding  zal te voorschijn komen.
          o  Zoom in en wijzig helderheid instellingen (lum settings), indien gewenst.
    -   Klik op 'Do it'
    -   Klik op 'Abort' om alle vertalingen te stoppen. (De momentele vertaling zal eerst worden afgemaakt)



Drukken op 'Help' zal een overzicht geven van de betekenis van de status- 'leds'.

Genereren van films



Films worden in AVI formaat gemaakt. Het is mogelijk om een ingebouwde eenvoudige generator te gebruiken
of een extern programma 'mencoder', dat eerst geinstalleerd moet worden.

    -  In het hoofdvenster:  Zorg ervoor dat 1 type afbeelding wordt getoond uit de sessie lijst, bijv. "Hrit".
        ('List' aan de onderkant van het hoofdvenster).
    -   Klik op 'Select all' of kies handmatig de items voor de film.
    -   Klik op 'Export'. Nu zal een lijst van het omzetten te voorschijn komen.
    -   Kies in dit nieuwe venster 1 kanaal te gebruiken voor de film.
    -   Kies 'Movie'.
    -   Kies 'Time id' als U de datum/tijd informatie op ieder frame wilt hebben (in de linker bovenhoek).
    -   Als een gezoomde film moet worden ontwikkeld:
           o  Klik op 'Preview' in het geopende venster (NIET in het hoofdvenster). Een speciaal voorvertoon 
               venster wordt geopend met de eerste gekozen afbeelding.
           o  Zoom in en wijzig de helderheid instellingen, indien gewenst.
    -   Klik op 'Do it' om de bewerking te starten.
 
Nu worden alle gekozen items omgezet in JPEG bestanden, in een speciale map. Na voltooiing zullen de jpeg
bestanden worden samengevoegd in een avi-geformateerd filmbestand.

Notitie bij het gebruik van voorvertoon venster:  De eerst gekozen afbeelding  zal worden getoond in dat voor-
vertoon venster. Als die afbeelding niet geschikt is om de instellingen te doen, dan:
    -   Kies eerst de afbeelding om de instellingen te doen.
    -   Klik op 'Preview'.
    -   Kies nu alle voor de film te gebruiken items.

Enige extra film kenmerken:

    -   Om kleurenfilms te maken schakel 'Colour' in (wijzig het kleuren ontwerp, indien gewenst).
    -   Om een beperkt aantal segmenten te gebruiken, vul het 'Segments' veld in, in het Translate venster.
         bijv. geef  8 of  6-8 om alleen die segmenten te gebruiken.
    -   Om incomplete frames over te slaan, schakel de toets 'Skip incomplete' in.
    -   Verander de maximum grootte, indien gewenst.  De voorinstelling, 2048x2048, kan worden gewijzigd
         in de Preferences. Wanneer bijv. een HRIT film is gemaakt (grootte 3712x3712), zal de grootte worden
         worden gewijzigd in 1856x1856 (3712/2). (Houd er rekening mee dat sommige film spelers, zoals
         mplayer, geen films kunnen hanteren die groter zijn 2048x2048).

Genereren van een film van enige dagen zal lang duren, speciaal het aanmaken van alle jpeg bestanden (96
voor 1-dag film) is zeer CPU intensief.
Als het AVI bestand is aangemaakt, zullen die bestanden worden verwijderd. U kunt echter ervoor kiezen die
bestanden te bewaren zodat ze weer opnieuw kunnen worden gebruikt. Als bijv. meer frames aan een film
moeten worden toegevoegd, moeten dan alleen de extra stukken worden omgezet.

In het Translate venster, tweede rij toetsen, naast 'Tempfiles':

    -   Reuse: genereer alleen wanneer nodig; temp  bestanden niet verwijderen
    -   Replace: genereer tempbestanden opnieuw, verwijder ze niet.
    -   Remove: verwijder alle gebruikte temp bestanden na ontwikklen van een film. (Bestanden niet gebruikt
        voor de film, worden niet verwijderd.

Alvorens een bestand te gebruiken, zal xrit2pic eerste controleren of de grootte correct is. Indien niet, zal het 
het bestand opnieuw genereren



Genereren van gezoomde/aangepaste afbeeldingen of films

Na drukken op 'Preview' in het popup venster (NIET in het hoofdvenster!) zal een voorvertoning tevoorschijn 
komen. Alle instellingen die in dat venster worden gedaan worden gebruikt voor het genereren van
afbeeldingen/films.

Als meerdere items zijn gekozen, zal alleen het eerste item een voorvertoning krijgen. Het is echter mogelijk om
een ander item te gebruiken voor de instellingen:

    -   Kies het item dat U wilt gebruiken voor de instellingen. Bijv. als U een film wilt genereren voor een dag,
         zult U de afbeelding van de middag willen gebruiken om de helderheidsinstellingen te doen.
    -   Klik op 'Preview'. Daarna kunt de groep items kiezen.        
    -   Doe de instellingen in het voorvertoon venster (zooming/panning, helderheidsinstellingen, anaglyph instel-
         lingen, indien gewenst).
    -   Kies 'Movie' en andere gewenste kenmerken.
    -   Klik op 'Do it'. Nu zullen de instellingen in het voorvertoon venster worden gebruikt voor alle gekozen
         items.

Opname

Xrit2pic kan de ontvangstlijst bijhouden en afbeeldingen laten zien als zij worden ontvangen (door Tellicast in
de map Received gezet).
Ook kunnen afbeeldingbestanden worden gegenereerd en onbewerkte (raw) gegevens kunnen automatisch 
worden verwijderd.
Klik op de Record toets.



Bijwerken van de lijst:

    -   Om een bijwerking te doen, klik op Update list 1x.
    -   Om continu bij te werken, klik Start updating. Het bijwerken gebeurt iedere 3 seconden (kan worden
         veranderd in Preferences).

Volgende kenmerken werken alleen gedurende continu bijwerking.

-  Show 'Live' :
    
    -   Om afbeeldingen te tonen, direct nadat zij zijn ontvangen, klik Show.
    -   Kies een satellietbron en geef een kanaal om te vertonen (als dat veld leeg is, worden alle kanalen over
        elkaar geschreven).
    -   Om afbeeldingen in kleur te zien, kies de 'Colour' toets. Voorinstelling van het kleurenontwerp: IR-016=
         rood/ VIS008=groen/VIS006=blauw, kan worden veranderd door het openen het 'Channel map' venster.

-  Genereer bestanden van onbewerkte (raw) gegevens:



    -   Kies 'On' in het 'Generate' vakje. De gegevens van het gekozen kanaal in 'Show live' vakje, zullen worden
        omgezet in een standaard beeldformaat.
    -   Kies 'Movie' om groter wordende films te maken.
    -   Kies 'Time id' als de datum/tijd informatie moet worden toegevoegd.

-  Verwijder onbewerkte (raw) gegevens:

    -  Kies 'Delete' in het 'Raw data' vakje en kies welke kanalen moeten worden bewaard. Alle gegevens, niet
       betrekking hebbende op de gekozen kanalen, zullen onmiddellijk worden verwijderd, nadat Tellicast de
       gegevens in de ontvangst map heeft gezet. Als echter de bestanden moeten worden gegenereerd (zie vorige
       punt), dan zullen alle gegevens worden bewaard totdat voldoende gegevens zijn verzameld om de vereiste
       ontwikkeling uit te voeren. Daarna worden de bestanden die niet zijn gekozen, verwijderd.
       Notitie: Alleen recent ontvangen gegevens (d.w.z. ontvangen nadat 'Start updating' is ingedrukt) worden 
       verwijderd. Oude gegevens in de ontvangst map worden niet verwijderd.
 
       Voor MSG, kunnen gegevens die verwijderd moeten worden, gespecificeerd worden per kanaal.

    -   Kies 'Keep unkown' om alle ontvangen niet-xrit bestanden te bewaren. Dat zijn de zipped bestanden van
         bijv. NOAA.

Behandelen van bestanden

Klik op de Archive toets in het hoofdvenster.
Klik op Update om de mappenlijst bij te werken. (Normaal alleen nodig de eerste keer na starten van het 
programma.).



Xrit2pic gebruikt de volgende map structuur om xrit gegevens te behandelen: 

    -   received: map waarin Tellicast de ontvangen gegevens opslaat.
    -   done: een help map; normaal zullen gebruikers dit niet nodig hebben, uitgezonderd als U, om welke 
         reden, bestanden wilt zoeken zonder xrit2pic.
    -   archive: bevat mappen voor iedere datum met gegevens van die datum.

Verplaats gegevens tussen received en archive: 

     -  Move to archive: Verplaatst gegevens van received naar archive; gegevens zijn verdeeld in submappen
         voor iedere datum.
    -   Move back to received: Verplaatst de inhoud van gekozen mappen terug. (Normaal is dit nooit nodig).
    -   Load selected: Laadt de gekozen map(pen) in een actieve lijst.
    -   Delete selected: Verwijdert de inhoud van gekozen map(pen).

Notitie: Naast HRIT/LRIT en AVHRR  gegevens, worden ook andere soorten gegevens uitgezonden, bijv.
    -   amsub
    -   hirs 



          
xrit2pic merkt die bestanden als 'unknown'. Zij zullen worden verplaatst naar map archive/unknown.

Verplaats gegevens tussen received en done map:
Normaal nooit nodig.
    -   Move to done:
    -   Move back from done:

Behandelen van geexporteerde/gegenereerde bestanden

Klik op de Exported toets.

Geexporteerde/gegenereerde bestanden (inclusief filmbestanden) in de bestemmingsmap, zijn nu zichtbaar. 
Bestanden kunnen worden bekeken met een extern kijkprogramma (zie 'Viewer programs' in Preferences)
of verwijderd. Tijdelijke gestanden, gebruikt om films te genereren, zijn ook bereikbaar via dit venster.

Proloog/epiloog bestanden



HRIT bestanden hebben een proloog en epiloog bestand voor iedere set kanalen (van een bepaalde tijd). In de
lijst worden zij direct onder een groep getoond, op hetzelfde niveau als de kanalen.
GOES LRIT bestanden hebben bijbehorend proloog bestand voor ieder kanaal. Die worden getoond op het-
zelfde niveau als de segmenten, een niveau onder ieder kanaal.

Momenteel gebruikt xrit2pic de proloog bestanden alleen om de positie van de 2 delen van het HRV kanaal 
eruit te halen. De gebruikte proloog gegevens zijn zichtbaar met Preview (kies eerste het proloog bestand in de 

lijst).
Om een proloog/epiloog bestand eruit te halen, kies het item en klik op 'Export'. 

Het is mogelijk om proloog/epiloog bestanden automatisch te exporteren, samen met de kanalen waartoe zij behoren. 
Zie 'Andere kenmerken'.

Andere kenmerken

Door drukken op de "More' toets (onderaan rechts), worden minder regelmatig gebruikte toetsen zichtbaar:

Bitselect

Alleen actief als afbeeldingen met meer dan 8 bits per pixel moeten worden ontworpen naar 8 bits per pixel.

    -   Genereren van kleur PPM (3x8bits) formaat naar 10-bits Wavelet.
    -   Preview: Afbeeldingen met meer dan 8 bits per pixel.

Items:

    -  [9:2]: De 8 MSB's (Most Significant Bits) zullen worden gebruikt; de 2 LSB's zijn verloren.
    -  [8;1]: De MSB zal gebruikt worden voor afsnijden, de volgende 8 bits zullen worden gebruikt/opgeslagen,
                 de LSB zullen verloren zijn.
    -  [7:0]: De 2 MSB's worden gebruikt voor afsnijden; de 8 LSB's zullen worden gebruikt/opgeslagen.

D.w.z. Een 10-bits pixel met waarde 261= 01 0000 0101:

    -  [9:2] geeft: 01000001 (LSB's '01' verloren)
    -  [8:1] geeft: 10000010 (LSB '1' en MSB '0' verloren)
    -  [7:0}geeft: 11111111 (MSB '01' verloren; pixel afsnijding op waarde 255)

De 'grijze' cirkel onder deze keuze laat zien hoe de helderheid van de afbeelding zal veranderen voor iedere keuze.

Invert

Keert de afbeelding om. Voor voorvertoning en export.



Notitie: In voorvertoning is ook een omkeerfunktie. Deze 2 funkties heffen elkaar op, d.w.z. beide aktief -> geen 
omkeer.

3D sh

Ingeschakeld als voor Anaglyph is gekozen. Wijzig de maximum verschuiving tussen links en rechts kijken 
(in pixels).

AVHRR Segment bereik

Kies een bepaald baanbereik om te bewerken/bekijken. Speciaal handig bij zeer lange METOP overkomsten.

       o  Start: start segment
       o  Nbr: aantal segmenten (0 betekent: alles, met een maximum van 102 minuten van segmenten, dat is 
           ongeveer 1 omloop.

Na klikken op de 'World map' toets, wordt een wereldkaart getoond met de baan van de gekozen satelliet. 
Het  gekozen deel van de baan is rood gekleurd.

o  Kies:  North pole, South pole, Full
o  Direction: North bound (in noord richting), South bound (in zuid richting)

Format

Bepaal het formaat van het output bestand.

Als voorinstelling zullen bestanden worden gegenereerd met de hoogst mogelijke kwaliteit.

    -  Als de bron een 10-bits Wavelet is: 16 bits PGM zal worden gegenereerd.
    -  Als de bron een 8-bits Wavelet is:  8 bits PGM zal worden gegenereerd.



    -  Als de bron een 8-bits JPEG is:  JPEG zal worden gegenereerd, zonder tussen-compressie.

De volgende formaten zullen worden gegenereerd:

                             Voorinstelling             PGM gekozen                    JPEG gekozen      Blauwe regel
                                                            zwart/wit          kleur                zw/wit of kleur       gekozen

LRIT(Meteosat)   JPEG 8 bits (1)      PGM 1 byte     PPM 3 bytes       JPEG 24 bit (2)       kies venster,
                                                                                                                                             pops up 

LRIT(foreign)       PGM 1 of 2           PGM 1 of 2      niet                     JPEG 24 bit             kies venster,                             
                            bytes                      bytes                ondersteund                                        pops up

HRIT uitgezon-    PGM 2 bytes         PGM 1 of        PPM 3 bytes       JPEG 24 bit              kies venster,
derd HRV                                          bytes                                                                          pops up
 
HRIT HRV          PGM 2 bytes         PGM 1 of        niet                      JPEG 24 bit
                                                          2 bytes            ondersteund

AVHRR              PGM 2 bytes         PGM 1 of        PPM 3 bytes       JPEG 24 bit             rah (voor wsat,                           
                                                         2 bytes                                                                       hrptreader)

EPS                    PGM 2 bytes          PGM 1 of       PPM 3 bytes       JPEG 24 bit              rah (voor 
wsat,                                                     

                                                          2 bytes                                                                       hrptreader)  
                                                     
Admin                 text (ASCII) formaat

Other                  binaire formaat

Opmerkingen:

    -  (1)  Gegenereerd zonder decompressie. Voordeel: geen extra verlies. Nadeel: beeld ondersteboven (voor
              de meeste gevallen).
    -  (2)   Origineel wordt eerst gedecomprimeerd, de segmenten worden samengevoegd, dan opnieuw gecom-
               primeerd. Nadeel: extra verlies, Voordeel: beeld kan met bovenzijde boven gegenereerd worden.

Opmerkingen over bestandsformaten

    -   JPEG 12 bits, ofschoon een standaard formaat, is niet erg algemeen. (Op het ogenblik wordt dit formaat
         niet meer door MSG uitgezonden.)
    -   PGM 2 bytes schijnt niet goed gedefineerd te zijn; sommige programmas gebruiken het zo genoemde 
         Little Endian formaat (LSB byte eerst), anderen Big Endian (MSB byte eerst). Het laatste schijnt meer 
         algemeen in gebruik te worden, dus zal xrit2pic het Big Endian formaat genereren. (Als er noodzaak is
         voor het Litlle Endian formaat, laat mij dit weten, dat is gemakkelijk toe te voegen.!)
    -   Als PGM8 (1 byte PGM) of PPM is gekozen, maar het origineel heeft meer bits per pixel, dan wordt het
         bit bereik bepaald door 'Bitselect' (d.w.z. bits 9...2,of  8...1 of  7...0 worden gebruikt).
    -   RAH ("Rob Alblas HRPT formaat) bevat alle kanalen en heeft ruimte om Kepler informatie toe te voegen



         enz. Leesbaar met mijn wsat programma en David Taylor's HRPTReader.

Non-gui mode

Toepassing:

xrit2pic [opties]
     opties:
     -h                                                   dit helpbestand
     -e                                                   non-gui voorbeelden
     -overlay_ files                                 laat beschikbare overlay bestanden zien
     -nogui                                             non gui mode
--------------------------------------------------------------------------------------------------------------
         opties voor locaties:
             -src <pad>                             pad naar de bron van XRIT bestanden (def.:  zie ini-file)
             -dest <pad>                           pad naar bestemming van omgezette bestanden (def.:  zie ini-file)
--------------------------------------------------------------------------------------------------------------
         opties voor bestandsformaten:
             -pgm                                      genereer PGM  (zie hieronder voor voorinstellingen)
             -pgm8                                    genereer PGM  (gedwongen naar 8 bits pp)
             -jpg                                        genereer JPG (zie hieronder voor voorinstellingen)
             -rah                                        genereer RAH van AVHRR
             -nolin                                      niet lineariseren van AVHRR
             -overwrite                              overschrijven als bestand bestaat ( voorinstelling: niet)
---------------------------------------------------------------------------------------------------------------
          opties voor kiezen wat te genereren:
             -europe                                 alleen het Europa deel (MSG)
             -gmap                                   'plane carree' kaartsysteem (geostat)
             -movie                                   genereert filmbestand
             -sat  (satelliet_bron)               zet alleen deze satelliet (MSG1, MET7 ...) om
             -type <H of  L of A)              zet alleen dit type (HRIT/LRIT/AVHRR) om
             -chan < kanaal_naam>          zet alleen dit kanaal om
             -segm <bereik>                     zet alleen deze segmenten on
             -date <jj-mm-dd>                 zet alleen deze datum om
             -time <hh:mm>                      zet alleen deze tijd om
             -pro                                      ook het proloog bestand eruit halen 
             -epi                                       ook het epiloog bestand eruit halen
             -inv                                       omkeren
             -temp                                    genereer een temperatuur kaart (alleen IR)
             -anagl [anagl_opts]                genereer een anaglyph
                   anagl_opts: <shft[:lmin[-lmax]]>
                                                          shft: pixel verschuiving links /rechts (voorinst. 20)
                                                          lmin: max. verschuiving bij deze helderheid (voorinst. 0)
                                                          lmax: min. verschuiving bij deze helderheid (voorinst. 512)
---------------------------------------------------------------------------------------------------------------                 
         opties voor meer-kanaal samenstellingen:
             -compose [type]                    maak pseudo kleuren afbeeldingen
                                                          type=optioneel; vis of airm of dust of fog
                                                          vis=vooringesteld



             -hrvlum                                 gebruik HRV voor helderheid  (hoge resolutie kleur)
             -inv <kanaalnaam>               dit kanaal omkeren
             -lmin <waarde>                    minumum waarde, deze waarde voor 'zwart'
             -lmax <waarde>                   maximum waarde, deze waarde voor 'wit'. 
             -inv <kanaalnaam>               dit kanaal omkeren
             -r  <kanaalnaam>[=waarde]  gebruik dit kanaal voor rood
             -g <kanaalnaam>[=waarde]  gebruik dit kanaal voor groen
             -b <kanaalnaam>[=waarde]  gebruik dit kanaal voor blauw
                                                          waarde= -100 ...100 (voorinstelling 000)
             -ro <offset>                          offset voor rood  (voorinstelling 0)
             -go <offset>                         offset voor groen (voorinstelling 0)
             -bo <offset>                         offset voor blauw (voorinstelling 0)
             -msb <msb>                         msb voor omzetten van 10 bits -> 8bits
                                                          =9, 8 of  7
--------------------------------------------------------------------------------------------------------------:
          andere opties:
             -test                                      niet genereren, laat alleen zien wat er gebeurt
             -log                                      genereer een log bestand 'xrit2pic.log' (in de bestemmingsmap) 
             -ol [=<lum>] [<type>]          voeg overlay toe aan de afbeelding
                                                         <lum>= overlay helderheid, 0 .. 255, (voorinstelling 255)  
                                                          <type>=coa(st), cou(ntry),  l (atlong), b (oth) (b=voorinstelling)

Voorinstelling van gegenereerde formaten: Zie Gegenereerde bestanden

Voor opties -chan, date en time zijn wildcards toegestaan.

In de non-gui mode kunnen xrit bestanden onmiddellijk worden omgezet in JPEG/PGM bestanden.
Voorbeeld: 

- xrit2pic -nogui -type H -chan Vis* -segm 3-7 date 04-02_* -time 21:00 -pro

Dit zal alle HRIT bestanden omzetten met kanalen VIS* (VIS006, VIS008), segmenten 3 tot 7, van februari
2004 en tijd 21:00, tesamen met hun proloog bestanden.

Het log bestand, indien gegenereerd, zal in de bestemmingsmap worden gezet. Dat bestand zal niet worden
overschreven; nieuwe informatie zal altijd worden toegevoegd.

Zorg ervoor dat U schrijftoegang hebt tot de bestemmingsmap, anders zal niets gebeuren en geen log bestand
zal worden aangemaakt!. (want dat bestand zou in de bestemmingsmap worden aangemaakt).

Zie 'Voorbeelden van nongui' opdrachten

Twee PC's gebruiken

Xrit2pic kan nuttig zijn in een 2-PC omgeving, maar heeft nog enige beperkingen.
In dit deel worden 3 methoden beschreven, evenals een gedetailleerde instelling beschrijving voor een van de
methoden.
De 2 PC's hebben de volgende functies:

  1.  Ontvangende PC (R)



          o  Uitgevoerd met Skystar 2 tuner
          o  Tellicast loopt
          o  Optioneel: xrit2pic laten lopen om onnodige gegevens te verwijderen
  2.  Verwerkende PC (P)
          o  Gegevens verbinding met de ontvangende PC
          o  xrit2pic laten lopen om gegevens te verwerken.

Er zijn verschillende methoden voor het gebruik van 2 PC's

Methode A: (zie gedetailleerde Windows instellingen hieronder)

     - Op PC 'R' verwijdert xrit2pic alleen ongewenste gegevens.(optioneel)
     - OP PC 'P' leest xrit2pic gegevens van de harde schijf  'R' van PC  'R' via gegevens verbinding en schrijft
        resultaten op harde schijf  'P' van PC 'P'.
 
Methode B:

    -  Op PC 'R' xrit2pic verwijdert alleen ongewenste gegevens.
    -  Op PC 'P' worden de overblijvende gegevens gekopieerd van PC 'R'.  
    -  xrit2pic leest onbewerkte (raw) gegevens van harde schijf  'P' en schrijft het resultaat naar dezelfde of 
       andere harde schijf op PC 'P'

Het voordeel, vergeleken met de vorige methode is dat het kopieer systeem op een lagere prioriteit kan lopen,
waardoor minder kans op verloren segmenten. Ook worden de onbewerkte gegevens slechts eenmaal van
hardeschijf 'R' gelezen.

Methode C:

    -  OP PC 'R' zet xrit2pic de onbewerkte gegevens om in een standaard beeldformaat en verwijdert daarna
        alle onbewerkte gegevens.
    -  Op PC 'P' worden de omgezette afbeeldingen gekopieerd van PC 'R'. 
    -  xrit2pic leest gegevens (in standaard beeldformaat) van harde schijf  'P' en schrijft het resultaat naar harde 
       schijf  'P'.

Voordeel: Verwerking is sneller (decompimeren Wavelet is processor intensief). Nadeel: Grotere bestanden
(als PGM formaat wordt gebruikt) of verlies van gegevens (als JPEG wordt gebruikt)
Notitie: 

Methode B is momenteel de beste methode: geen gegevens verlies voor verwerking en bestanden relatief klein.

Instellingen voor toegang op afstand

Methode A met gebruik van Windows

In het kort, als Uw bestanden op Uw ontvangende PC zijn in:
o  C:\aa\bb\cc
 dan moet U delen met:
o  C:\aa\bb
en in xrit2pic op de verwerkende PC kunt U de bestanden op de ontvangende PC vinden in:
o  \\rec_pc\bb\cc
( met rec_pc de netwerknaam van Uw ontvangende PC.)



Nu in detail:
Verondersteld wordt de standaard Tellique installatie, d.w.z. de received directory is:
Program Files\T-Systems\BusinessTV-IP\received op de Ontvangende PC.

     - Op de ontvangende PC: Zet  'BusinessTV-IP' map als 'Shared' (delen) 
            o Ga naar Program Files\T-Systems
            o Klik rechts op de map 'BusinessTV-IP' en kies 'Properties'
            o Klik op 'Sharing'
            o In 'Sharing en protecting: Network' schakel 'Shared' in. 
            o Klik op OK
    Controleer dat de map is gedeeld:
            o Ga naar 'My network locations'
            o Kies van het menu "View->Details"
            o Controleer dat 'BusinessTV-IP' aanwezig is onder 'Local network'. In de tweede kolom ziet U 
               het pad naar die map:
               \\pcnaam\BusinessTV-IP  (pcnaam is de naam van Uw ontvangende PC)

     -Op de verwerkende PC:
            o Start xrit2pic en ga naar 'Received'
            o Geef het afstandpad in het veld 'Directory to add':
               \\pcnaam\BusinessTV-IP\received
                Dit is dezelfde mapnaam gevonden op de 'Ontvangende PC ' maar met de map received toegevoegd.
            o  Klik op "Load selected" (toets onderaan het venster).
                Nu moet de inhoud van de map op de 'Ontvangende PC' op afstand, zichtbaar zijn in het hoofdvenster.
            o  Als U deze instelling wilt opslaan: Ga terug naar 'Received' toets en klik op 'Save it'.

Opm: De map die gedeeld is gemaakt ('BusinessTV-IP' in dit voorbeeld) is niet NIET bereikbaar door xrit2pic,
maar de mappen onder die gedeelde map ('received' in dit geval) wel. Dat is de reden waarom de map die 
received bevat deelbaar is gemaakt en NIET received  zelf!.
 
 Wat werkt op afstand:
 
 o Bekijken/vertalen van xrit gegevens.

Wat kan misschien op afstand niet werken: (uit proberen)

 o Verschuiven van (archief) bestanden, van de ontvangende naar verwerkende PC.
 o In ieder geval archivering
 o Verwijderen van bestanden op de andere PC.

Inrichten van mappen



Wanneer geen mappen zijn gedefineerd, worden de voorinstellingen gebruikt.

Definieer map met XRIT bestanden:

    -  Kies 'XRIT Dir Select' (zie bovenaan het venster)
    -  Klik op 'Browse dir.' en loop door  naar de gewenste map.
        Klik op 'OK'.
    -  Klik op 'Add to list'. 
    -  Herhaal wanneer meer lokaties moeten worden toegevoegd.
    -  Kies een map in de lokatie lijst.
    -  Klik op 'Load' om de inhoud van de map te laden.

Nu zal het programma naar het hoofd venster springen en de inhoud van de gekozen map is zichtbaar.

Enige opmerkingen: 

    -  Het doorlopen van mappen kan soms tijd nemen wanneer de map met XRIT-bestanden is opgegeven.
       Dat is omdat die map een enorme hoeveelheid bestanden bevat (meer dan 10000 na een dag van ontvangst)
    -  Als alternatief kan de map ook in het 'Directory to add' veld worden getypt. Iedere keer wanneer een map 
        scheidingsteken is getypt ('/', of voor Windows , '\'),  zal de inhoud van de map worden bijgewerkt.



    -  Gebruik via netwerken is mogelijk. Voor Windows, typ het eerste deel van het pad in het 'Directory to
        add' veld, bijv:  \\computer_naam\c\
        (Notitie: Geen ':' na de schijfnaam!) Na het typen van de laatste '\', wordt de map inhoud van de verderaf
        liggende computer bekeken en zichtbaar gemaakt en doorlopen is mogelijk.

Voorkeuren

Xrit2pic  slaat zijn instellingen op in een voorkeur bestand  xrit2pic.ini. Dat houdt ook in de map instellingen
die in het vorige deel zijn besproken
U kunt de programma voorinstellingen terug krijgen door te klikken op de 'Load defaults' toets.
Sla de instellingen op door op Save it te klikken. De map lijst (zie Inrichten van mappen) wordt ook opgeslagen,
inclusief de map zelf!
Als het programma een volgende keer wordt gestart, zal het voorkeur bestand worden gelezen en onmiddellijk de
map laden die was gekozen vlak voor het opslaan van het voorkeur bestand.

    -  Window height: Hoogte van het totale xrit2pic venster in pixels.
    -  Font size: Grootte van de tekst.  0=voorinstelling=120 (Notitie: Misschien werkt dit niet goed
        met Linux! Dat moet worden geregeld).
    -  Memory Usage: Minimize: Als voorinstelling zal de complete afbeelding in het geheugen worden gehouden
        na kilkken op 'Preview'. Voordeel is dat opnieuw schrijven en opslaan snel is (geen extra lees/decomprimeer
        proces nodig). Nadeel is dat meer geheugen nodig is. 1 HRV afbeelding heeft 124 Mbytes geheugen nodig!



        Wanneer Memory usage: Minimize  is gekozen , dan zal de afbeelding NIET in het geheugen worden 
        gehouden.
        Dus het opnieuw schrijven en opslaan is langzamer. (Notitie: Als JPEG bestanden worden gegenereerd, dan
        worden de gegevens in het geheugen niet gebruikt, dus er is in dat geval geen snelheid voordeel). 

 

      
   -   Update:
          o  cycle: herhaalcyclus in seconden
          o  Show channel: Bepaalt welk kanaal te laten zien tijdens bijwerken. Wanneer leeg, worden alle ka-
              nalen getoond. Wildcards zijn toegestaan, bijv: VIS*
   -    AVHRR mode: Alleen controleren in combinatie met MSG Data Manager.
   -    Delete old files: Bepaal de ouderdom van de bestanden die zullen worden verwijderd, met het menu
        "File->Delete old".



        
   -   Viewer programs: In dit deel zal het kijkprogramma dat moet worden gebruikt, worden gedefinieerd
        (een voor JPEG bestanden, een voor PGM). Verondersteld wordt dat het kijkprogramma het beeldfor-
        maat als onderwerp accepteerd. Voor ieder kijkprogramma kunnen opties worden gedefinieerd, om er-
        voor te zorgen dat het beeld altijd met de bovenkant boven is.

        Als geen kijkprogramma is gespecificeerd, worden de volgende ingebouwde programmas gebruikt:
             o  Linux
                      - voor JPEG: xv, omgekeerde scan optie: -record 180
                      - voor PGM: wsat, omgekeerde scan optie: -sn
             o  Windows 
                     - voor JPEG: i_view32, onmgekeerde scan optie: /rotate_r/rotate_r
                     - voor PGM: i_view32, omgekeerde scan optie: /rotate_r/rotate_r

In het voorbeeld:

            o  Voor jpeg wordt xv gebruikt. De uitgevoerde opdracht is: xv bestand.jpg
            o  Voor pgm/ppm wordt wsat gebruikt. De uitgevoerde opdracht is: wsat -w 500 -h 500 -i bestand.pgm
            o  Voor avi  wordt mplayer gebruikt. De uitgevoerde opdracht  is: mplayer -fps 3 bestand.avi -loop 0 & 

Opm: Wanneer geen '%s' is toegvoegd, wordt de bestandsnaam als laatste onderwerp aan het programma
toegevoegd.. Als '%s'aanwezig is, dan zal dit worden vervangen door de bestandsnaam. (Vergelijk in dit voor-
beeld avi met pgm).



   -    Juiste scan richting: Wanneer niet gekozen, zullen de afbeeldingen worden opgeslagen zoals zij zijn
         verzonden.  Bijv. MSG afbeeldingen zijn  verzonden zuid naar noord, dus opgeslagen MSG bestanden
         zullen ondersteboven staan. Wanneer gekozen, dan zullen gegenereerde PGM/PPM bestanden 

altijd met de
         bovenkant boven zijn. Zie ook Flip toets in Preview.
         Notitie: JPEG bestanden zullen altijd zijn zoals ze worden verzonden (MSG en MET bestanden onder-
         steboven, vreemde formaten bovenkant boven).
   -     Auto export proloog/epiloog. Wanneer de 'pro/epi' toets wordt geactiveerd, dan zal het 

exporteren van
          een kanaal ook resulteren in het exporteren van de bijbehorende proloog en/of epiloog 

bestanden.
-      Overschrijven. Wat te doen als een te genereren bestand al bestaat. Gegenereerde bestanden 

hebben
        unieke namen, gebruiken tijd en kanaal. Er zijn 3 methoden om bestaande bestanden te 

behandelen
        (zie 'Overwrite'):

              o  Vraag toestemming om te overschrijven.
              o   Overschrijf altijd, vraag niet.
              o   Overschrijf nooit, vraag niet ( betekenis: bestand zal NIET worden gegenereerd. Als View 

is 
                   gekozen  zal de viewer worden gestart en zal het bestaande bestand lezen). 
     

   -    HRV full globe: Wanneer ingesteld, genereert HRV met afmetingen 11136x11136.



   -    Film codeer programma: Definieer opdracht voor het uitvoeren van een codeerder, om films te genere-
         ren.
        Wanneer geen codeerprogramma is gedefineerd, zal mencoder worden gebruikt:

           o mencoder mf://%s -o %s -mf type=jpeg-ovc lavc -lavcopts vodec=msmpeg4v2 

        Een snelheid optie kan apart worden gedefineerd; voorinstelling is:

           o -mf fps=1

        Dat resulteert in een film met een frame per seconde. Als een andere opdracht wordt gebruikt, zorg ervoor
        dat die opdracht 2x %s bevat; xrit2pic zal de eerste vervangen door het input bestand, het tweede door
        het outputbestand.

   -    Diepte kanaal voor Anaglyphen:
            o Channel: Dit wordt gebruikt voor diepte informatie, als de Dptchan toets in het Preview venster 
               wordt aangeklikt.
            o  Invert: Wanneer aangeklikt wordt het diepte kanaal omgekeerd voor het wordt gebruikt voor diepte

                informatie. Nodig als een IR kanaal wordt gebruikt.

  -    Europa grenzen:
           o  Bepaal positie (offset_x,offset_y) en afmetingen (breedte,hoogte) om het geo-stat.pic te laten zien als
               de toets 'Europe' gekozen.
           o  Verander de naam van de "europe" toets wanneer nodig.
           o  Druk 'Default' als U de ingebouwde Europa grenzen wilt.

Notitie: Ieder deel van de aardeschijf  kan op deze manier worden gekozen.



   -    Bepaal bestemmings map:
            o  Klik op 'Browse dest. dir'.
            o  Loop naar de map waar de gegenereerde bestanden moeten worden gezet.
            o  Klik op OK in de bestandsmanager.
                (De bestemmings map kan ook handmatig worden opgegeven in het 'Destination directory' veld.)
            o   Gebruik 'Split destination dir'om bestanden van verschillende types op te slaan in hun eigen map.
                 (MSG, METOP, NOAA, DWDSAT enz.) 
   -    Bepaal de bron map:
            o  Klik op 'Browse src dir'.
            o  Loop naar de map waar Tellique zijn bestanden neerzet.
            o  Klik op OK in bestandsmanager.
                (De bestemmings map kan ook handmatig worden opgegeven in het 'Source directory' veld.)           

Notitie: Dit is een andere manier om de bron map te bepalen; zie ook Inrichten van mappen.



   -    Bepaal Norad (Kepler) bestand:
           o   Type de bestandsnaam (voorinstelling: weather.txt)
           o   Klik op 'Search', om te controleren of het bestand gevonden is. Zie de tap 'Misc' in preferences voor
                geschikte locaties voor dit bestand.
   -    Bestandsnaam formateren:
           o   Haal vinkje weg op 'Use fileformat' en geef een formaat specificatie voor een  persoonlijk bestands-
                naamformaat. Het venster laat de codes zien die aan het formaat worden toegevoegd.
                Enige voorbeelden:

        format      example result             comment
        picture       picture.jpg                      always same filename  %s%c_%t   MSG1VIS6006_061220_1200.jpg

  De time/date specificatie "%t" mag worden vervangen door een meer persoonlijke tijd specificatie. Formateren 
  zal  worden gedaan volgens de strftime() C-functie, uitgezonderd voor de volgende % codes:
  %k, %S, %c, %n, %r, %t
  Enige codes:

%a        De afgekorte naam van de dag van de week, plaatselijk gangbaar.

%A       De complete naam dag van de week, plaatselijk gangbaar.

%b        De afgekorte naam van de maand, plaatselijk gangbaar.

%B       De complete naam van de maand, plaatselijk gangbaar.

%C      Het getal van de eeuw (jaar/100) als een 2-cijferig geheel getal.  (SU)

%d       De dag van de maand als een decimaal getal (bereik 01 -31).



%D      Gelijk aan %m/%d/%y. (Yecch-alleen voor Amerikanen. Amerikanen moeten zich realiseren dat 
             in andere landen %d/%m%y  algemeen is. Dat betekent dat internationaal dit formaat dubbel-
             zinnig is en niet moet worden gebruikt). (SU)

%e        Hetzelfde als %d, de dag van de maand als een decimaal getal, maar een nul vooraf wordt ver-
             vangen door de spatie.  (SU) 

%H       Het uur als een decimaal getal, met gebruik van de 24 uur klok (bereik 00 - 24).

%I        Het uur als een decimaal getal, met gebruik van de 12 uur klok (bereik 00 - 12).

%j        Dag van het jaar als decimaal getal  (bereik 001 - 366).

%p       Of    \x{2018}AM\x{2019}  of   \x{2018}PM\x{2019}  volgens de gegeven tijd  of de 
overeen-

             komende reeksen voor plaastelijk gebruik. Namiddag is \x{2018}pm\x{2019} en 
middernacht

             \x{2018}am\x{2019}.   
           

               

Opslaan/terugzetten van gui status

Voor de volgende vensters kan de gui status worden opgeslagen/teruggezet na het opstarten:

    -  Hoofdvenster (toets 'Main', inclusief menu 'View after export')
    -  'Translate list' (zonder kanaal keuze)( komt te voorschijn, na klikken op 'Export' of  'Preview', als meer-
        dere kanalen zijn gekozen).
    -  'Channels to keep' (komt te voorschijn na klikken op 'Remove' in het hoofdvenster, deel 'New Files'.

Om de gui satus op te slaan:

    -  Zorg ervoor dat ieder venster waarvoor U de gui status wilt opslaan open is en alle toetsen in de gewenste
       stand.
         o  Voor 'Channels to keep' moet U 'Remove' inschakelen om keuzen te wijzigen; daarna kunt U 'Remove'
             weer uitschakelen.
    -  Van het Edit menu kies item 'Preferences' en klik op 'Save gui state'.

Het bestand wordt opgeslagen in xrit2pic.gini  in de courante map. Zoals xrit2pic .ini kan het op een centrale
lokatie gezet worden; zie Installatie

Aanhangsels

Installatie

Dit is een lijst van alle noodzakelijke/betrekking hebbende items om xrit2pic te laten lopen:

categorie                    naam              nodig                update                    waar te krijgen



Hoofdprogramma        xrit2pic.(exe)   altijd                  iedere nieuwe          http://www.alblas.demon.nl/wsat

                                                                   vrijgave 
Bibliotheek                  GTK               altijd                   nooit                       http://www.alblas.demon.nl/wsat 
                                                                                            (Windows)
Bibliotheek                  JPEG              altijd                   nooit                        http://www.alblas.demon.nl/wsat
Bibliotheek                  Wavelet          altijd                    nooit                       http://www.alblas.demon.nl/wsat
Init bestand                  xrit2pic.ini       nee (defaults)       -                             gegenereerd door xrit2pic
Gui ini bestand             xrit2pic.gini      nee(defaults)        -                            gegenereerd door xrit2pic 

Ondersteunende          bzip2(.exe)      alleen                   nooit                       http://www.alblas.demon.nl/wsat 
 programma                                        AVHRR                                            (Windows)
Overlay bestanden       met8*.gif         Geostat.              nooit                       Eumetsat
                                   etc.                  Meteosat
Kepler bestanden         noaa.txt           AVHRR             iedere maand?        http://www.celestrak.com
                                                           lengte/breedte
                                                           calc. 

Linux

Installatie van xrit2pic is eenvoudig; het is een kwestie van het plaatsen van het programma en zijn archiefbe-
standen op de juiste plaats.

Er zijn 2 bestanden die moeten worden gedownload:

    -  xrit2pic.gz::  het programma
    - decompr.gz: 2 lib. bestanden

Verondersteld wordt dat gtk is geinstalleerd. Dat is normaal het geval (denk ik) op Linux machines. Download 
en installeer anders gtk-1.2.

Ontzip de 2 bestanden en zet het resultaat in bijv. $HOME/bin.
Voor AVHRR is bzip2 nodig. Die is normaal ook aanwezig in iedere Linux distributie.

Windows

Installatie van xrit2pic is eenvoudig; het is een kwestie van het plaatsen van het programma en zijn archiefbestan-
den op de juiste plaats.

Er zijn 4 of 5 bestanden te downloaden:

     -  xrit2pic.zip:  het programma
     -  gtk_dll.zip;  8 dll's
     -  decompr.zip:  2 dll's
     -  xrit_install.exe:  het installatie programma
     -  bzip2.exe:  (nodig voor AVHRR)

Voor het bijwerken (update) is het normaal voldoende om alleen xrit2zip te downloaden en de installer te laten
lopen.

Installatie met gebruik van het installatie programma:



    -  Zorg ervoor dat de 3 zip bestanden en xrit_install.exe in dezelfde map zijn gedownload..
    -  Laat xrit_install.exe lopen.
    -  Kopieer bzip2.exe naar dezelfde map als waar xrit2pic is. (Wordt niet door de het installatie programma
        gedaan). 
    -  Maak een verbinding naar c:\Program Files\xrit\xrit2pic.
         o Ga naar het programma, klik rechts hierop en van het menu dat verschijnt, kies "Make Link" (of zoiets).

Installatie:  (als het installatie programma niet gebruikt wordt)
    
    -  Maak een map: c:\Program Files\xrit  (Als er geen c:\ Program Files is, probeer een andere schijf).
    -  Zet alle zip bestanden in die map.
    -  Ontzip de 3 zip bestanden, bijv. met gebruik van Winzip
    -  Kopieer bzip2.exe naar dezelfde map.
    -  Maak een verbinding naar c:\Program Files\xrit\xrit2pic.exe.
         o  Ga naar het programma, klik rechts hierop en van het menu dat verschijnt, kies "Make Link"
             (of zoiets).

Voorbeelden van non-gui opdrachten

De volgende opdracht vertaalt alle HRIT bestanden met een bestandsnaam beginnende met VIS, voor iedere
dag met UTC tijd van 12:00. Alleen segmenten 7 en 8 worden aan de afbeeldingen toegevoegd 
(wat Europa is).

xrit2pic -nogui -type H -chan VIS* -segm 7-8 -time 12:00

Hierna is een voorbeeld om de vertaling 'altijd' te doen, iedere dag als de ontvang map is leeggemaakt.

- Script voor Linux:

xrit2pic -nogui -type H -chan VIS* - segm 7-8 -time 12:00 -log rm /home/user/from_msg/received/*

Start het als een hoofdklus, iedere dag rond middernacht (tenminste enige minuten voor de tijd dat de te ver-
talen bestanden zijn gegenereerd!)

- Voor Windows:

xrit2pic -nogui -type H -chan VIS* -segm7-8 -time 12:00 -logdel c:\from_msg\received\*.*

Start het met de 'Task scheduler'.

Details betreffende maken van films

Xrit2pic maakt films op de volgende manier:

     -  Een speciale map 'movietmp' wordt aangemaakt, onder de bestemmingsmap. Als die al bestaat, dan zal
        de inhoud worden verplaatst naar een sav map (in dezelfde temp. map)
     -  Alle gekozen afbeeldingen worden gegenereerd in jpeg formaat, in die temp.map
              o  Als 'Reuse' is gekozen:
                      -  Controleer of het bestand met de juiste grootte al in de sav map bestaat, indien positief, 



                          wordt dit bestand naar de temp. map verplaatst. Anders wordt het jpeg bestand gegenereerd
                          van de onbewerkte (raw) gegevens.
                      -   Als 'Replace' is gekozen:  (Re)genereer altijd ieder jpeg bestand.
     -  De jepg bestanden worden gecombineerd in  een avi geformateerd film bestand.
     -  Als 'Remove' is gekozen: Alle temp. bestanden worden verwijderd.

Als een externe codeerder 'mencoder' wordt gebruikt, dan gebeurt in principe hetzelfde, 'mencoder' combineert
ALLE bestanden in de temp. map in een film bestand; dat is de reden waarom alle bestanden eerst naar de sav.
map worden verplaatst. Voor de interne film generator is dit niet nodig.
Voordeel van de mencoder is dat verscheidene codecs mogen worden gebruikt. 
De voorinstelling is: msmpeg4v2.
De opties van mencoder, of zelfs de gehele opdracht, kunnen worden vervangen door iets anders, zie voor-
keuren en de mencoder handleiding. Dus andere codecs of een geheel verschillend codeer programma kan wor-
den gebruikt.

Details betreffende het maken van anaglyphs

Meteosat gegevens bevatten geen 3D informatie. Om een 3D illusie te krijgen worden de linker en rechter af-
beeldingen gegenereerd met gebruik van de helderheid van iedere pixel. Wolken zijn helder en hoog, land is
relatief donker en laag, wat aangeeft waarom helderheid kan worden gebruikt voor diepte informatie.
Van iedere pixel wordt een duplicaat gemaakt in rood en cyaan; de verschuiving tussen de twee is groter als
als de helderheid lager is ('land').

Instelling

    -  Als een speciaal kanaal nodig is voor de diepte, klik op toets 'Dpthchan'. (Zie Voorkeuren  welk kanaal
        is gebruikt)
    -  Klik op de "Init" toets; typ 'r' om het venster te verversen.
    -  Stel Lbnd in tot de delen die als laagste niveau getoond moeten worden, rood gekleurd zijn (typ 'r' na
        iedere instelling).
    -  Voorstel: Zee en wolkenvrij laagland.
    -  Stel Hbnd in tot de delen die als hoogste niveau getoond moeten worden, groen gekleurd zijn.
       Voorstel: Wolken moeten enkele groene vlekken krijgen.
    -  Klik weer op "Init" en typ 'r' om te verversen.

Als land /kustlijnen moeten worden toegevoegd:

    -  Klik 'Overlay' in het hoofdvenster. Dat zal witte kust/land grenzen geven. Het 3D effect is dat de overlay
       op grote hoogte schijnt te zweven.
    -  Klik "OL_3D" als de overlay op landniveau zou verschijnen.
    -  Stel de helderheid van de overlay in met OL_lum. (Speciaal in 3D moet de overlay niet te helder zijn).

Anaglyphen zijn mogelijk voor zwart/wit en kleuren afbeeldingen en films. Zwart/wit geeft betere resultaten dan
kleuren anaglyphen.

Installatie van mencoder en codecs (NIET nodig als interne film generator
wordt gebruikt!)

Installatie mencoder voor Linux



Download mplayer en codecs van de Mplayer site.

Installatie mencode voor Windows

Ga naar de Mplayer site en download MPlayer-mingw32-1.0pre5.zip
Zet mencoder.exe in een map die in het zoekpad staat. (bijv. c:\windows).

Ga naar de codecs site en download win32codecs-essential-240040703.tar.bz2
Decomprimeer en zet de dll bestanden in c:\windows\system.

Enige opmerkingen

De gegenereerde bestanden kunnen zeer groot zijn; volledige HRV afbeeldingen zijn 5568 x 11136. Als U
problemen krijgt met kijkprogrammas, door tekort aan geheugen, kunt U wsat proberen. Dat programma kan
afbeeldingen laten zien met praktisch onbeperkte grootte, op een zeer kleine computer. (Nadeel is dat het op-
nieuw schrijven, na een zoom actie, een beetje langzaam is). Het kan niet jpeg lezen, dus U moet in PGM
formaat schrijven als U het wilt gebruiken. (Bestandsgrootte van HRV in PGM formaat is ongeveer 124
Mbytes).

Programma informatie

Xrit2pic is geschreven in C en C++, met gebruik van:

     -  GTK voor het grafische deel
     -  IJG (Independent Jpeg Group) code voor de JPEG decompressie
     -  Eumetsat code voor de Wavelet decompressie

 

 
                          

   



 
            
                 

         

   
   

 

  

           
  

      

           

       

          
    
      



     

 

 


